PHP Kompilieren und Installieren

In der momentanen LTS Version Ubuntu 14.04 Trusty Tahr wird PHP in der Version 5.5 ausgeliefert, was ich grundsätzlich begrüße aber im Falle meines Arbeitsrechners ungünstig ist, da wir für ein Projekt aufgrund von externen Modulen auf PHP in der Version 5.4 angewiesen sind.

Es ergab sich also das Problem das ich irgendwie PHP in der Version 5.4 für installieren musste. Da Ubuntu die Version 5.4 nicht mehr in den offiziellen Paketquellen bereitstellt habe ich zuerst in den PPA’s geschaut, wo ich leider nichts passendes gefunden habe. Zwar hätte ich noch die Möglichkeit gehabt es aus den Paketquellen von Debian zu installieren, da dass aber erfahrungsgemäß in Kopschmerzen bei Paketabhängigkeiten und Konflikten endet habe ich mich dazu entschieden selbst Hand an zu legen.

Continue reading →